你的账号被盗了吗?CF漏洞强制登陆

事件起因

昨晚上群里吵的沸沸扬扬的,原因是CF居然可以直接登陆账号,不需要密码。原来是有人找到了CF的漏洞,开发了一款CF强登工具。

作者来自小嘀咕论坛,大概和散人有什么关系,相信大家都用过散人的外挂。

用这个软件,很多明星的CF账号被封,CF点用光,目前网络已经全部封杀此消息,果核博客为大家谈谈这个事件


作者发布强登外卦以后,不知是作者发明还是破解者发挥,一批拥有强登外卦的玩家,开着强登器和已经非法的外卦登录游戏,直接导致大量账号被封停3天、7天、180天不等。

其中不乏CF明星中招。

比如据说70kg、EVEN在直播中被顶号,账号被封180天,贴吧已经火起来了。

爱拍红人也不能幸免,经常号称代开幻影复仇、却有诈骗嫌疑的红人“月下”账号被强登,继而被封。

陈子豪、白鲨、V3据说都遭殃了,名人如此可能可以解封,小老百姓怎么办?

在各个QQ直播群、YY直播群里,小学生们还在提供着他们所知道的人民币玩家账号和大区,供主播强登和封号,大量账号被封。

QQ截图20150829073216.png

图片来自百度贴吧

应用原理

CF快速登陆,向腾讯发送数据包(目测未加密)

拦截封包,替换封包。因为未加密,所以多试几个账号就可以了

按照这个原理,腾讯所有游戏都无法避免!

易语言代码如下:

.版本 2

.子程序 _网截1_调发送, 整数型
.参数 调用者信息, 调用者信息, 参考
.参数 套接字句柄, 整数型, 参考
.参数 网络数据, 网络数据, 参考
.参数 调用方式, 整数型, 参考

.如果真 (寻找字节集 (网络数据.到字节集 (), 到字节集 (“你自己的QQ”), ) ≠ -1)
    网络数据.从字节集分配 (字节集替换 (网络数据.到字节集 (), 寻找字节集 (网络数据.到字节集 (), 到字节集 (“你自己的QQ”), ), 取字节集长度 (到字节集 (“你自己的QQ”)), 到字节集 (“需要登的QQ”)))
    返回 (#拦截操作.更改调用)
.如果真结束
返回 (#拦截操作.默认调用)

*******************

Cache_120e87e99421097..jpg

解决方案

开启游戏锁,建议打开所有游戏锁,这个软件被反编译后,得到的资料即可用于所有可以快速登陆的腾讯游戏。

164046jl41g6lnolqri664.jpg


后记

作者一晚上赚了100多万了,昨晚上动身跑越南,今早消息,已经被抓。如此年轻的技术员。

还有一些人,拿着破解版强登外卦,冒充代理商或者作者,兜售强登器,付款以后立刻拉黑、踢出群。

发表评论: